基础网络升级(二)

上一篇做的主要工作其实只是打通了两个机房的内网。升级完成之后,由原来的『无序』变得相对『有序』。

由于历史原因,起初的网络不得不如此的冗长 :-(

不过,经过研究发现,本质上依然无序的二层结构,除了启用了 ip routing。因为,机房与机房之间的连接是通过两台二层机器完成的,这两台机器纯粹充当了网线的角色,使用 access 相连接,同时又出现了 SPOF 的问题。

基础网络升级(一)里面完成的部分操作

于是,最简单的,也是最清晰的就是将打通两个机房的光纤直接连接在两个三层设备上,之间做 EC,同时在两个端口启用配置 IP,启用路由,做到真正的三层路由功能,之间单独划分一个网段,比如 192.168.1.0/255.255.255.248 的网段。

本次操作

二层要做的事情很简单,只要加条 ip default-gateway 到对应的 vlan 的 IP 就好了。要注意的是,不要在新老机房之间混建 VLAN,不然就没法指路由了。
三层要做的事情多一点,首先是要启用三层的 EC,也就是要在对应的端口上配上 IP。三层机器默认走的是二层的协议,要使用三层的路由功能,需要关闭 switchport 功能:
switch(config)# interface gi1/1/1
switch(config-if)# no switchport
switch(config-if)# channel-group 48 mode on

switch(config)# interface gi2/1/1
switch(config-if)# no switchport
switch(config-if)# channel-group 48 mode on

switch(config)# interface port-channel 48
switch(config-if)# no switchport
switch(config-if)# ip address 192.168.1.1 255.255.255.248

对于这种比较核心的端口,可以指定一下 speed 以及 duplex。因此,三层的 sh ru 如下显示:
interface Port-channel48
 no switchport
 ip address 192.168.1.1 255.255.255.248
 duplex full
!
interface GigabitEthernet1/1/1
 no switchport
 no ip address
 channel-group 48 mode on
!

而普通的二层的则如下:
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on
!        

除了上面一点之外,当然要做一下静态的路由,比如,新机房的内网 IP 是 192.168.2.0/24,对端三层设备的 IP 是 192.168.1.2,则在本端(192.168.1.1)需要做一条如下的路由:
ip route 192.168.2.0 255.255.255.0 192.168.1.2

在对段同样需要做一条类似的路由。

上面说的只是最核心的一部分,除此之外,由于原来服务器指向的默认 gw 不是新的 VLAN 的 IP,需要在执行上面语句之前修改完毕,否则会出现一些比较麻烦的问题,这个问题会在后面提到。另外一点就是做这些比较关键的操作的时候,需要跟服务商的 NOC 确认好,等他们那边确认没有问题之后再操作,否则 5min 能够搞定的事情会被无限期的延长,最终受损失的还是我们。